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SharePoint 2010 is a complex system that has many gadgets and
functionality associated with it. As SharePoint 2010 is starting to be used

more – the subject matter is becoming more technical and complex.
Therefore, many users just need to use SharePoint 2010 for their daily jobs
and thus this powerusers guide does that. It peels away the pure technical
details and shows one step by step many key features and functionality for

the casual SharePoint 2010 user. The following document was created using
a local SharePoint Foundation version – as well as a SharePoint Enterprise

edition.
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Overview of Users

SharePoint has several user bases which are worthy of an overview – these include:

Business Owner/Champion – this is typically the individual(s) in the organization whom
make the decisions on what is needed for the business. They may suggest new
features and functionality which should be implemented. They also will champion
SharePoint as a platform in the various business meeting settings they partake in.

Power User/Site Owner – this is typically an individual(s) whom maintain a section of a
SharePoint site and subsites on a daily basis. They are responsible for content creation
and updates as well as layout and permissions to the site they manage.
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Site Collection Administrator – this is an individual(s) whom are responsible for the
whole site and subsites. A site collection administrator has responsibility for additional
features and functionality which usually involve customizations.

System Administrator – this is an individual(s) whom typically are responsible for the
servers themselves and usually are in charge of backups of data and server
maintenance.

Developer – this is an individual(s) whom typically write the code that encompasses
custom features and functionality which are beyond out of the box techniques that are
needed and asked for.
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How to Add a Folder

Follow the steps below to add a new folder to a document library.

Folders can be nested – meaning one can have one folder inside another.

1.Navigate to the
administrative side of
the document library.
This example shown
requires a user have
contribute access or
greater.

Typically this is done by selecting Site Actions -> View All Site
Content – then
selecting the desired document library  see examples below:

Then in this case I’ve selected Documents
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2. In the ribbon under
Library Tools click the
Documents  tab

3. From the ribbon,
select the “New
Folder” option.

4. Enter a name and
click on the Save
button.

The folder is created as named
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How to Add Documents

Follow the steps below to add new documents to a document library.

1. From the site
where the
document library
is located click
Site Actions ->
View all Site
Content then
under Document
Libraries click on
the desired name
of the document
library on the
page to which
content should
be added.

2. To upload a
document or
documents, click
on in the Ribbon
from Library
Tools ->
Documents ->
Upload
Document and
select to Upload
Document or
Upload Multiple
Documents.
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3. Upload
Document:  Click
on the Browse
button to find the
desired
document, much
like you would
attach a
document to an
email and then
click OK.

4. Upload Multiple
Documents:
Drag the
documents from
the local PC or
file share into the
box that says
‘Drag Files and
Folders Here’
Click OK.

NOTE:  Documents must be located in an accessible location, such as a user’s pc or a
network file share or server. Also it is a good idea to not display more than 5000 items
in a folder.
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How to Modify Existing Documents

Follow the steps below to modify documents in a document library.  These steps can
also be used to change the name of a folder.

1. From the site
where the
document library is
located click Site
Actions -> View all
Site Content then
under Document
Libraries click on
the desired name
of the document
library on the page
to which content
should be
modified.

2. From the
Documents or
Library view
hover the mouse
over the desired
document. Click
on the drop-down
arrow that
appears to the
right of the
document.

From the menu,
select the “Edit in
Microsoft Office
<application>”
option.

This option will
change depending
on the Office
application that is
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related to the
document.

The document will
open in the correct
application.  Make
any necessary
changes and click
the save button.
Changes will be
saved to the site.

NOTE:  If a user simply clicks on a document, the document will open and the user will
be able to make changes, but the changes will not be saved to the site.  When a user
opens a document by simply clicking on the document, they open a Read-Only copy of
the document.  They can save their changes to their desktop, file share or network
server but the changes will not be saved into the document library for others to see.
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How to Delete Documents

Follow the steps below to delete a document from the document library.

These steps can also be used to delete a folder.  NOTE: If a folder is deleted,
everything under the folder will also be deleted.

1. From the site
where the
document library is
located click Site
Actions -> View All
Site Content then
under Document
Libraries click on
the desired name
of the document
library on the page
to which content
should be deleted.

2. From the
Documents or
Library view, hover
the mouse over the
desired document.

3. Click on the drop-
down arrow that
appears to the
right of the
document.
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4. From the drop-
down list, select
the Delete option.

5. A pop-up will
appear to verify
that the document
should be deleted.
Click OK if the
document should
be deleted.

6. The document will
be deleted from
the system.
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Recycle Bin

If a document or folder is deleted from the document library by accident, the user by
default has 30 days to recover the document.  This is done by using the Recycle Bin
option on the site.

To recover a deleted document or folder, follow the steps below.

1. Click on the “Recycle Bin”
link that is located in the
left hand column of the
site.

2. Find the document or
folder in the list.

3. Mark the document by
placing a check in the
box next to the
document.

4. Click the “Restore
Selection” option.

5. A pop-up dialog box will
be displayed.  Click on
the OK button if the
correct document has
been selected and should
be restored.
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File and URL Administrative Notes

 Document URL Length

The maximum length of a URL for a file is 260 characters.  This includes the folder
structure above the file. Thus a folder name and a file name cannot be more than 128
characters. It should be noted that in SharePoint if a file or folder has a space – it will be
shown with a %20 in the URL.

If a file is attempted to be uploaded that has a combined URL that is too long an error
will be displayed:

“The specified file or folder name is too long. The URL path for all files and folders must
be 260 characters or less (and no more 128 characters for any single file or folder name
in the URL). Please type a shorter file or folder name.”

 Allowed Document Types

The following document types are commonly allowed to be added to a Document
Library.

 Microsoft Word (.doc)

 Microsoft Excel (.xls)

 Microsoft PowerPoint (.ppt)

 Microsoft Project (.mmp)

 Microsoft Visio (.vsd)

 Adobe Acrobat (.pdf)

 Text (.txt)

 Rich-Text document (.rtf)
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 Images (.jpg, .gif, .bmp)

 HTML page (.htm, .html)

 URL

 Special Characters/Restricted Characters

The following characters cannot be used when naming folders or files (<document
name>.extension).

 / - forward slash

 \ - back slash

 : - colon

 * - asterisks

 ? – question mark

 " – double quotes

 < - less than

 > - greater than

 | - pipe

 # - pound

 <TAB>

 { - left bracket

 } – right bracket

 % - percentage

 ~ - tilde

 & - ampersand
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PERSONAL NOTES:
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Content Editing

Follow the steps below to edit existing content on the site or team site you manage or
add content to.

1. From the page that
content is to be edited
select Site Actions ->
Edit Page.

2. Likely a Content Editor
web part will house the
content that needs
changed. Therefore
place the cursor in the
text block that needs
changed or highlight the
area that needs
changed and make the
desired edit(s) as you
would while using any
text editor.

3. In the example here the
text webpage has been
highlighted.
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4. In the Font menu the
Bold is then selected
and using the live
preview the text is
shown right away
bolded.

5. On the right the
text is now
bolded.

6. If this were the
only change to
be made to the
page an editor
would then
select the Page
tab then Save
and Close –
which would
then essentially
publish the
page.

7. If further edits to
the page were
so desired other
font elements
from the Font
menu could be
selected.
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8. Additionally
other edits to
the page could
be done by
using the
Paragraph
menu.

9. Selecting the
Styles menu
allows for
content font
Styles to be set.

10.To spell check a
page select the
Spelling
selection and
the language
that the content
is written in.

11.To add a
desired
markup select
the Markup
Styles
selection then
the desired
selection.
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 Page
Tools/Web
Parts

12.To add new
sections or
media type
content select
from the Page
Tools tab ->
Insert.

13.To add a new
Text block to a
page select
that option. The
Content Editor
will appear on
the page – to
add content
click the link
that says ‘Click
here to add
new content’.

14.To move the
text editor to a
different
location on the
page simply
select the
editor and
move it to the
desired area.
This same
process can be
followed for any
of the Page
Tools set.
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15.To add an
image select
from the Page
Tools tab ->
Insert ->
Image.

16.The part is
added to the
page as an
Image Viewer
object.

17. In the Image
web part box
that appears to
the right click
the … of the
http:// item and
enter in the
URL of where
the desired
image is
located and
click OK. It is
then
recommended
to click the Test
Link link to
make sure the
image is typed
correctly. Enter
in other
Alternative Text
and select
desired
Alignments
before clicking
Apply -> OK.
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18.To add a media
item select
from the Page
Tools tab ->
Insert -> Video
and Audio.
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19.The Media
Web Part is
added. Where
it says ‘Click
here to
continue’ do so.
NOTE: This is
a Silverlight
Control.

20.Select the
desired
Properties,
Player Styles
and Size.

21.Select the
Change Media
selection then
select where
the desired
media is
located.

22. In this example
From Computer
was selected –
and thus
selecting
Browse then
selecting the
media to be
uploaded and
where it is to be
uploaded
should be
followed and
click OK when
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done.
23. If the media

item is
uploaded with
success a
message as
shown is
displayed and
at this point
one can add a
Title for the
media item and
then click Save.

24.To add a web
part item select
from the Page
Tools tab ->
Insert -> Web
Part.

25.Select from the
Categories
menu on the
left hand side
then from Web
Parts on the
right hand side
the desired
selection.
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26.On the far right
hand side a
short
description of
the web part is
given and if so
desired where
it says Add
Web Part to –
make a
selection which
in most cases
will be Main
which is the
center of the
page. Click Add
to add the web
part to your
page.

27.The web part is
added to the
page.

28.Common
attributes of
web parts are
the following:

Appearance – the title bar and height and width of the web part
Layout -  how the webpart is positioned on the page.
Advanced – how the user interface will be displayed.

Under Appearance there are several items of interest:
Title – the title of the webpart that is displayed.
Height and Width – the actual height and width in pixels of the
webpart.
Chrome State – if selected this indicates if the web part is
displayed minimized or maximized.
Chrome Type (Title and Border) – the default is that there is not
a title bar or border, or a title only, border only and title and
border.
Under Advanced there are several of interest:
Allow close – allows for the ability to have users close or not
close the web part – if a check box is checked or not.
Allow editing in Personal View – if checked only site owners and
designers can customize the web part.
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Title URL – Adding a URL makes that URL a clickable item that
users will goto when clicked.
Help URL – If a URL is added then a help button is depicted.
Title Icon Image URL – Allows if a URL is added for an image to
be displayed in the title bar.

29.To change the
properties of
the added web
part click in the
upper right of
the web part
the drop down
arrow and
select Edit Web
Part. On the
right hand side
make any
adjustments
then click Apply
-> OK.

30.To add a list
item select
from the Page
Tools tab ->
Insert ->
Existing List.
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31.Select the
already existing
list from the left
hand side Web
Part menu.
Then on the
right hand
menu in the
About the Web
Part select the
Add button and
the list is added
to the page.

32. If a web part is
added
accidently it
can easily be
deleted.
Assuming one
is in edit mode
select the web
part properties
and click
Delete.

33.Click OK when
prompted

34.Another option
to be aware of
is if a web part
holds
information that
is sometimes
needed (for
example a
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message for
new yearly
benefits or a
holiday
message) – the
web part and
its information
can be closed
from view for all
users,
assuming one
is in edit mode
select the
properties of
the web part
and select
Close. The web
part is then
closed.

35.To re- add the
web part to the
page at a later
time – from edit
mode select
the Page Tools
tab -> Insert ->
Closed Web
Parts. On the
right hand side
select the we
part that was
previously
closed then on
the right hand
side select
Add.
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NOTE: It is not recommended to have too many closed web-part on a said page as
resources in loading the closed web parts will be utilized which may slow page
optimization.
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Follow the steps below to create new pages on a SharePoint site. The New Page
section covers how to create a single web page. The New Site section covers how to
create a whole new site which thus can have web pages off of the main sites page
which are typically all interrelated by subject matter.

 New Page

1. Navigate to the
site where a page
is needed to be
added. NOTE: To
add a new page
to a site a user
needs designer
level access or
better. Select Site
Actions -> New
Pages

2. Under
New page name:
Enter in a desired
name in this case
here I have
entered in Test.
Click Create after
naming the page.
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3. The
page is created
and the content
entry screen will
look as such.

At this point
adding new
content can be
added following
the information
presented in the
Content Editing
section.
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 New Site

1. In this
section
creating a
whole new
site is
presented –
thus to start
click Site
Actions ->
New Site

2. Select
the desired
installed
template.
Enter in a
Title and URL
name and
then Click
Create. In this
example here
a Team Site
type has been
selected.
NOTE: That
each template
that is
available has
a description
that when
selected is
shown on the
right hand
side – so thus
selecting the
template for
the deemed
purpose is a
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reality.

3. At this
point adding
new content
can be added
following the
information
presented in
the Content
Editing
section.
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 More Options

1. In this section
creating other
types of assets
is reviewed –
this includes
document
libraries, lists
etc.

2. On the left hand
side in this
example
Document
Library was
selected.
KMO_DOCS
was placed in
the name field
and then the
Create button
was selected.
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3. The result is
processed.

4. The document
library is created
and displayed
and thus items
can be added to
the library by
clicking the Add
new item link.

5. If changes to the
Library settings
are desired to
be made from
the Library
Tools  select
Library then in
the far right
hand corner
select Library
Settings
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6. Here a user can
perform many
useful
operations such
as changing the
name of the
document library
under the Title,
description and
navigation link,
deleting the
document library
and setting the
permissions for
the document
library amongst
other items

7. Other options in
More Options
can be created
as desired.
Note: Do not
name different
asset types with
the same name
– thus creating a
list and a
document library
with the same
name will result
in errors being
thrown.
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 Lists

8. In this section
creating lists
and libraries is
reviewed. To
create a list
select Site
Actions ->
More Options.

9. Select Custom
List and on the
right hand side
name the list –
in this case it’s
been named
KMO_LIST.
Click Create
when done.

10.The request is
processed.

11.The list shell is
shown and to
add items to
the list one
should select
Add new item
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12.One can then
enter in the
content of the
list then select
the Save
button

13.The item(s)
are then
displayed.

14. If additional
data is to be
stored in the
list – a user
can select
from the List
Tools tab ->
list -> Create
Column

15.A user would
then select the
name of the
column in this
example; it
has been
called name
and the type of
information to
collect. They
would then
scroll down
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16.Additional
Column
Settings which
include if the
information is
required,
allows for
unique values,
maximum
number of
characters, a
default value
as well as if
the column
should be
added to the
default view
should be
entered and
selected. A
user would
click OK when
done entering
in the desired
information.

17.The column is
then displayed
in the list. If
content is
desired to be
entered into
the existing
item – that
item should be
selected and
the Edit Item
selected.
Content can
then be
entered into
the new
column and
saved.
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18.If changes to
the List
settings are
desired to be
made in the far
right hand
corner of the
screen in the
Settings
options select
List Settings.

19.Here a user
can perform
many useful
operations
such as
deleting the
list, setting the
permissions
for the list as
well as create
columns and
change the
order display
of existing
columns.
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20.Those items
under General
Settings are
explained
here:

Title, description and navigation – this is used to change the
display name and can be used to add a description as well as
decide if a link appears on the quick launch bar.

Versioning settings -  this is used to turn off and on content
approval, set versions of items as well as set if one has to
check out items before editing.

Advanced settings – this section has several miscellaneous
settings that can be utilized which include those for content
types, item level permissions, e-mail notifications, attachments,
folders, searching and datasheets.

Rating settings – used to enabled/disable the five star rating
system available.

Audience targeting settings – allows for the ability for content
to be targeted to a said user base.

Metadata navigation settings – allows for keywords from a list
to be used in the navigation tree view.

Per-location view settings – allows for the setting of which
Views can be displayed for a folder or content type.

Form settings – used for InfoPath if utilized on the list or
document library.
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21.The title,
description and
navigation is an
important and
useful item and
deserves a
description. In
this example,
we will assume
that the
previously
created
KMO_DOCS
library needs
changed so
from Library
Tools -> Library
-> under
Settings select
Library
Settings. Click
under General
Settings the
Title,
description and
navigation link.
In the Name
field – place the
cursor in that
field and make
the desired
changes, then
if desired add a
description text
and select
whether to add
the link to the
quick launch or
not then select
Save.

HTTP://WWW.KMO.NAME
mailto:ONEILLWEBSITE@VERIZON.NET


W E B S I T E : H T T P : / / W W W . K M O . N A M E
E - M A I L : O N E I L L W E B S I T E @ V E R I Z O N . N E T

U S E  A L L  C O M M A N D S  A T O W N  R I S K

22.For a list item
the same
process would
be followed
thus in this
example, we
will assume
that the
previously
created
KMO_LIST
needs changed
so from List
Tools -> List ->
under Settings
select List
Settings. Click
under General
Settings the
Title,
description and
navigation link.
In the Name
field – place
the cursor in
that field and
make the
desired
changes, then
if desired add a
description text
and select
whether to add
the link to the
quick launch or
not then select
Save.
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Note: A list or library has two names, the name in the URL and the display name. When
either item is initially created the name entered is what will be used as the URL name.
In this case the document library is for examples sake KMO_DOCS – so the URL would
be: http://myservername/sites/KMO_DOCS/Forms/AllItems.aspx if the name of the
document library was changed to KMO_DOCS2 – the display name would be
KMO_DOCS2 but the URL would remain with the KMO_DOCS in the name.
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 Content
Approval

23.In this section
the notion of
content
approval for a
list or
document is
reviewed. In
this case – the
manual
process for
content
approval is
described. This
can also be
accomplished
via a workflow.
The first step is
to turn content
approval on in
the desired list
or document
library. Thus, in
this example,
from the
KMO_DOCS
document
library select
from the
Library tools ->
Library tab
under Settings
the Library
Settings
selection then
under General
Settings select
Versioning
Settings and
under Content
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approval select
Yes and click
OK.

24.In this case
maneuver to
the document
library and click
Add new item.
Browse out to
add the desired
item select it
and click OK.
If prompted for
Metadata enter
it in and click
Save.

25.The document
is displayed in
the library – at
this point hover
over the
document to
see its
properties. In
this case since
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the uploader
has admin
access – the
Approval
Status is
Approved.

26. If approval is
required an
individual with
Approver rights
would have to
view the
properties of
the item and
select to
Approve/reject
it. Additionally
in the
document
library view the
item would
appear with an
Approval
Status of
Pending.
Once the
approver
hovers over the
document and
selects
Approve/Reject
then selects
Approved and
OK would the
document be
available for all
users to see
the document.
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NOTE: With content approval turned on – only two groups of users can see the
document. The person who created or uploaded it and any user whom has Approver
rights (by default includes those in the site owners group and those with designer rights)

 Folders and
Make “New
Folder”

27.In this section
the notion of
lists and
libraries being
divided into
folders similar
to that of
windows
explorer is
reviewed.
 Thus, in this
example, from
the
KMO_DOCS
document
library select
from the Library
tools -> Library
tab under
Settings the
Library Settings
selection then
under General
Settings select
Advanced
settings and
under Folders
select Yes and
click OK.
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28.From the
breadcrumb
– select the
document
library in this
case it’s
KMO_DOCS
then from the
Library Tools
tab ->
Documents -
> the New
Folder option
should now
be available
if it wasn’t
previously.

NOTE: This option can be utilized with Calendars, Discussions, Surveys or Wikis.
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Navigation Items

Navigation is of vital importance to the sites that one creates in SharePoint – in
SharePoint 2010 several customization items are available. The navigation available is
different depending if the site is created via a published or non-published site template.

1. If the site was
created as a
published site, to
add a new tab or
link go to Site
Actions -> Site
Settings -> under
Look and Feel
click Navigation.

2. Global navigation
if where a user
sets how the top
level navigation
should appear.
The global
navigation bar
appears on every
page of the site
across the top.
Thus, in this case
the ‘Display the
same navigation
items as the
parent site’
displays the
navigation items
the same as the
root site. Thus,
this indicates the
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default setting for
sites that are not
top-level sites.

This indicates
that the site
should use
(inherit) the
global navigation
items that the
parent site uses.
The ‘Display the
navigation items
below the current
site’ displays the
navigation items
that appear from
the site one is on
downward.
Thus, it indicates
that the site's
global navigation
items should be
populated by
items below the
site. The ‘Show
subsites’ and
‘Show pages’ are
the checkbox
options so one
has the option

of turning them
both on and off.
The maximum
number of
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dynamic items to
show within this
level of
navigation is
essentially how
many items will
be displayed in
the navigation.

3. Current
Navigation is the
navigation that is
essentially on the
current site one
has accessed.
Thus as with
global navigation
the ‘Display the
same navigation
items as the
parent site’
displays the
navigation items
the same as the
root site.

It specifies that
the current
navigation does
not inherit parent
site navigation by
default.

For a given site,
selecting this
option usually
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causes the data
source to start
with the current
site's immediate
parent site, or
one level up in
the site
hierarchy.

The ‘Display the
current site, the
navigation items
below the current
site, and the
current site’s
siblings’ displays
those items by
indicating that the
data source
starts with the
current site's
immediate parent
site, or exactly
one level up in
the site
hierarchy. It
includes the
current site and
the site's siblings,
but trims out
children of the
sibling nodes.

The ‘Display the
navigation items
below the current
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site’ displays the
navigation items
that appear from
the site one is on
downward.  The
‘Show subsites’
and ‘Show
pages’ are the
checkbox options
so one has the
option

of turning them
both on and off.
The maximum
number of
dynamic items to
show within this
level of
navigation is
essentially how
many items will
be displayed in
the navigation.

4. Sorting - has
several options.
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5. Navigation
Editing and
Sorting – in this
area one can
configure how
they want their
navigation to
display.

6. Clicking Add
Heading allows
one to enter in a
desired
information
piece, URL,
description and
audience to
target the
heading to.
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7. Clicking Add Link
allows one to
enter in a desired
information
piece, URL,
description and
audience to
target the link to.
Typically Links
appear under
desired
headings.

8. Selecting an item
allows one to
select Move
Down so the item
appears down in
the navigation –
or clicking Hide –
hides that
information
heading/link.
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9. To unhide an
item that was
previously hidden
select it and
choose Show.
Additionally the
item can be
moved by
selecting the
Move Up or
Move Down
actions.

10.Show and Hide
Ribbon – this
essentially turns
off and on the
feature set of the
ribbon.

11.Note the Show
and Hide Ribbon
only works when
the publishing
feature is
activated – this
can be verified by
going to Site
Actions -> Site
Settings -> under
Site Actions ->
Manage Site
Features ->
SharePoint
Server Publishing
is Active.
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Navigation Panel Views (Tree View)

On the default left hand navigation – there are three views – quick launch, tree view and
both quick launch and tree view.

1. To set the desired panel view from
Site Actions -> Site Settings under
Look and Feel click Tree view

2. To display items that make up the
navigation of the site – on the left
hand side click Enable Quick
Launch and click OK

3. Going back to one’s home page
with the Quick Launch enabled –
the links will appear as such – in
this case my lists, libraries and
pages are displayed.
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4. With just the Enable Tree View
selected under Site Actions -> Site
Settings – the left navigation is
depicted as such:

5. With both Enable Quick Launch
and Enable Tree View selected
under Site Actions -> Site Settings
more content is displayed.

6. The left navigation is depicted as
such:
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Site Theme

One can control the fonts, colors and theme that are displayed across a site and
subsite.

To set the desired theme, follow the steps below:

1. From Site Actions ->
Site Settings under
Look and Feel click Site
Theme.

2. Select ‘Inherit theme
from the parent of this
site’ – if the theme used
on the top level site
should also be used for
the current site.
Otherwise select
‘Specify a theme to be
used by this site and all
sites that inherit from it’
if the theme and
attributes selected will
be used by the current
site and all site
underneath it – in the
tree.
Select the desired color
and font.

3. Select the preview
button to see the site as
it will look given the
current attributes
selected.
After previewing the
page – click either
‘Apply the selected
theme to this site only’
or ‘Apply the selected
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theme to this site and
reset all subsites to
inherit this setting’ and
click Apply. To cancel
the full operation click
the Cancel button.

SharePoint Views

Views are a useful way to organize and group information that is needed to be viewed in
a certain customized way. Views have several features which should be described:
Columns – the basic building block of a view – columns represent the data stored or
the data calculated to be displayed.
Sort – is the make-up of how the data should be displayed. Typically two columns can
be used – and usually users want data sorted by data or by an alphabetic nature.
Filter – is used usually as a way for a user to filter down the exact data they want
displayed – examples include current date or the current user of the site thus typing in
[Today] or [Me] as the column values respectively would display such data.
Inline Editing – When checked allows a user to select an edit button to edit that row –of
data – however this option is only available if the view is set to a default view.
Tabular View – This allows for the checkboxes in each row to be shown or hidden
Group By – Allows for the columns to be grouped so one can expand or collapse them
as needed.
Totals – Columns that are numeric in nature can be totaled.
Style – Views can be changed by applying in-line styles to them.
Folders: Folders or Flat – List with folders can be shown with folders or flattened to
show all of the data inside the folders.
Item Limit – A limit can be placed on how many items are displayed in a views result
return set.
Mobile – a view can be turned off or on for mobile viewing.

1. Maneuver
to the
pages
content
where a
view of
data is
desired –
usually
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this is a
list or a
document
repository.
Select Site
Actions ->
Edit Page.

2. Select in
the List
Tools tab
the List
option.

3. In the
Manage
Views
selection
select
Create
View

4. Choose
a view
format.

5. In this
example
– the
Standard
View was
selected.
Where it
says
View
Name: -
the view
needs to
be
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named in
this case
it was
called
Test_Vie
w. The
columns
desired
for the
view to
be
displayed
need to
be
checked
as well
as the
order
that the
columns
should
appear in
the view
need
selected.
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6. In the Sort
field select
from the drop
down menu
the desired
field that the
view should
use to sort
on.

7. Scroll down
and expand
the Item Limit
selection and
set the
Number of
items to
display: to the
desired
amount – in
this case I set
it to 10 from
the default of
30.

8. Expand the
Folders
selection and
select Show
all items
without
folders. This
allows for the
documents
from all
folders to be
shown.

9. Click OK
once all
desired items
are selected.
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 Custom
Column
View

This view example shows how to add a column using a built-in
variable. In this case, the view displays the item based on its
age.

1. In the
Manage
Views toolbox
under Current
View: select
the view
previously
created.

2. Select Create
Column.
Note: Unless
one is at the
root of the full
site (example
http://yourweb
server.domai
n.com) then
this column
will be ad-hoc
meaning it will
only be
available at
the actual site
it was created
in. If a column
is to be used
site-wide a
user should
go to the root
of the full site
and select
Site Actions -
> Site
Settings then
under
Galleries
select Site

For a column to be used across the entire site and subsites:
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columns then
Create

3. In the Column
name: enter
in
CustomDate
and select
under ‘The
type of
information in
this column
is:’ the
Calculated
(calculation
based on
other
columns)
In the
Formula field
enter in
[Created] + 7

Under ‘The
data type
returned from
this formula
is:’  select
Date and
Time

Uncheck ‘Add
to default
view’ then
select OK

4. Verify under
the Current
View that the
desired view
is selected. In
this case here
– I have
selected the
Test_View.
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5. In the List
Tools tab
select List

6. Select Modify
View ->
Modify View

7. Check the
custom
column
previously
created in this
case it’s
called
CustomDate.
Also check
the columns
Created and
Type.

8. In the Sort
option select
the Created
field and the
descending
order option.

In the Filter
section select
the
CustomDate
field and
select ‘is
greater than’
and enter in
[Today]
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Click OK so
the view is
saved.

9. The active
view will then
be shown and
in this
example it is
the Custom
Column View.
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 Calendar
View

This view example shows how to add a calendar view so that
items of value can be placed into a useful calendar.

1. Once on the
page where a
calendar view
is desired
select from the
List Tools tab -
> List -> Create
View.

2. Under Choose
a view format
select Calendar
View.

3. Under the View
name: - enter in
a name in this
case its
Test_Cal_View
and select
under View
Audience, the
desired
audience.
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4. Under Time
Interval select
the desired
Begin and End
item columns to
be utilized in
this case here
I’ve used
Created and
CustomDate
from the
previous view
example.

5. Under
Calendar
Columns select
the columns
that will
displayed in the
view.  In this
case I’ve made
it easy and
selected the
display field to
be the title.
NOTE: the title
field is
required.

6. Select the
default scope.
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7. Select the
desired Filter

8. Select the
desired Mobile
options and
how many
items to display
in this view –
the default is 3.

9. Click OK when
done and the
view is saved

10.The view is
then displayed
in a calendar
format.
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11.Selecting an
item shows the
data and if so
desired the
item can be
edited by
clicking Edit
Item.

12.The edit can be
made and then
the Save button
selected.
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SharePoint Permissions

Permissions in SharePoint are a broad topic – the following will be described with the
Site Owner mind frame.

Essentially, the easiest way to handle permissions is by groups. Most firms utilize Active
Directory which ties into SharePoint and then administrators add the users to the
desired groups that are created. By default a top level site has three groups:

Owners -> whom will have full control of the site

Members -> whom can contribute content to lists and libraries

Visitors -> whom have read only access to the site

 Create a group The steps below go over how to create a custom group which
then can be populated with users.

1. Maneuver to the
site where the
group should be
created and
where you
currently are
likely an
administrator/site
owner.

2. Select Site
Actions -> Site
Settings and
under Users and
Permissions
select the Site
permissions link
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3. On the ribbon
menu select
Create Group

4. Name the group,
enter in a group
owner (example
domain\user),
select who can
view the
membership of
the group and
who can edit the
membership of
the group.

5. Select if users
are allowed to
join/leave the
group and if
auto-accept
requests are
allowed
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6. Choose the
permission level
of the group and
click Create

7. The group is
created and now
additional users
can be added by
selecting New ->
Add Users

8. In the Select
Users click the
People Picker
and either enter
in the users by
name and click
the check mark
or click the
browse book and
select the
desired users
and click OK.
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9. If the browse
book was
selected the
screen will look
as such and
entering in a
users name after
the Find option
and clicking the
magnifying glass
will find the user
– then clicking
Add – will add
the user into the
middle pane.
Repeat the
process for each
user whom
should be added
to the group –
when done click
OK.

 View
permissions
of a group

The steps below go over how to view permissions of a group.

1. Sometimes
viewing the
permissions of a
group is needed
so it is known
what users have
access.
Thus, maneuver
to the site where
the permissions
should be viewed
and where you
currently are
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likely an
administrator/site
owner.
Then from Site
Actions -> Site
Settings under
Users and
Permissions click
Site permissions

2. The groups for
that site are
shown.

3. In this case – the
Approvers link
was clicked and
the users whom
are members of
that group are
displayed.
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 Site Action
areas

A site owner typically will be working in four areas:
Site Actions -> Site Settings
Site Actions -> Edit Page
Site Actions -> New Page, New Document Library, New Site
and More Options
While in a list or library (Settings -> List or Library Settings)

1. Under Site
Actions -> Site
Settings a Site
Owner likely will
see the following
options:

2. If a user is a
subsite owner
and doesn’t have
rights to the top
level site then
while going to
Site Actions ->
Site Settings they
will not have
access to the
following:
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3. A Site Collection
administrator will
have many more
options to
choose from.
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 Item Level
Permissions

4. It is possible to
set permissions
at the item level
of
announcements,
calendars,
custom lists,
discussion
boards, links and
surveys and
tasks.
To set such
permissions one
would access the
list or library
settings menu
and select the
List or Library
Settings then
Advanced
Settings. In the
Item-level
Permissions one
would then check
the desired
setting. Click OK
when done.
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 Search
Visibility

5. It is possible to
set if items when
searched for
show up in
results. To set
this access the
list or library
settings menu
and select the
List or Library
Settings then
Advanced
Settings. In the
Search one
would then check
the desired
setting. Click OK
when done.
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List and Library Versioning

Versioning is mainly used so one can revert back to a previous version of an
item/document and view a previous version.

1. The first item
one needs to do
in regards to
versioning is to
enable it.
Typically it is
also a good idea
to enter in the
number of major
versions that get
kept. In this
example here
Create major
versions of each
document has
been selected
and 5 major
versions will be
kept with the
notion that after
five versions get
uploaded the
oldest version
will be deleted
(and not kept)
once a sixth
version is
uploaded.

2. Additionally, it
should be noted
that minor
versions for
draft purposes
can be kept by
selecting that
version and thus
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if this is selected
then versions
ending in .0 are
major versions
and versions
ending with non-
zero extensions
are minor
versions.

Content Types

A content type essentially defines the attributes of a list item, a document, or a folder.
SharePoint 2010 has several built in content types and site columns that may meet your
needs. The below steps show how to best use content types – note there are essentially
two kinds of content types – Site content types which are available to the root site and
all its parents (subsites) and List content types which are essentially Site content types
that are added to a list and then customized just for that lists purpose.

1. To create a custom Site
content  type – from
Site Actions -> Site
Settings – under
Galleries select Site
content type

2. Click Create and enter
in the desired data – in
this example I will
create a custom
content type to be used
with Folders so that a
notes field is added. In
this case I have named
the item Custom Notes
and selected Folder
Content Types as the
Parent Content Type
and Folder as the
second Parent Content
Type. The item will be
placed into an existing
group called Custom
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Content Types. When
done with selections
click OK.

3. On the page that
displays under the
Columns section click
Add from the new site
column.

4. In the new Site Column
screen that appears
create a Column called
Notes which is a Single
line of text and click
OK.

5. Now maneuver to the
Document Library
where the content type
will be utilized. From
the Library Tools tab
select Library -> then
Library settings.

6. Under General Settings
select Advanced
Settings.

7. Under Content Types
select Yes to Allow
management of content
types and then click
OK.

8. Under Content Types
select Add from
existing site content
types.
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9. Select the custom
Content Types from the
list and click Add – then
select OK.

10.Maneuver to the
document library and
from Library Tools ->
Document – under New
Document will now be
the Custom Notes
Field. Thus select this
option.

11.A New Folder screen
appears and now a
Notes field is present
which can be used to
store the custom
information for this
folder. Enter in the
desired information and
then click Save.

12.So that the notes field
displays in the default
view of the document
library select from
Library Tools -> Library
then select the  Modify
View selection
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13.Select under
Columns the Notes
field and select
where it should
appear in the view –
then click OK.

14.The folder is now
displayed with the
entered Title and
Notes (in this
example it is Test)

15.To add the same
Custom Content
Type to a list –
maneuver to that list
and select from the
List Tools tab – List -
> List Settings

16.Under General
Settings select
Advanced Settings

17.Under Content
Types select Yes to
Allow management
of content types and
then click OK.

18.Under Content
Types select Add
from existing site
content types
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19.Select the custom
Content Types from
the list and click Add
– then select OK.

20.From List Tools ->
Items select New
Item and select the
Custom Notes

21.A New Item screen
appears and now a
Notes field is
present which can
be used to store the
custom information
for this list item.
Enter in the desired
information and then
click Save.

22.So that the notes
field displays in the
default view of the
list select from List
Tools -> List then
select the  Modify
View selection

23.Select under
Columns the Notes
field and select
where it should
appear in the view –
then click OK.
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24.The list item is now
displayed with the
entered Title and
Notes (in this
example it is Test)
Therefore, this same
process can be
utilized to create a
variety of custom
information items.
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Exporting and Importing using Excel

In SharePoint 2010 – users now have the ability to better export and import using tools
such as Excel.

To utilize this functionality, follow the steps below.

1. From a document library select
the Library Tools tab – select
Library then select Export to
Excel.

2. Click the Open button when
prompted

3. Click Enable if prompted

4. The data set will open in excel
5. Optionally – one could instead of

Open select Save and save it to
their desktop
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6. Then open the data file which
will connect with SharePoint and
open the item

7. If one has Excel installed on the
computer – then importing from
Excel into SharePoint is an
option to do so from Site Actions
-> More Options -> select Import
SpreadSheet

8. On the right hand side select
Create:

9. Name the item, enter in a
description then browse out to
where the Excel file is located
and click Import

10.The Excel document will then
open up and display the Import
to Windows SharePoint Services
list menu:
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11.In the Range Type one has
three options Range of Cells,
Table Range or Named Range
to choose from:

12.In this example, I have chosen
Range of Cells and then
selected the option under Select
Range which brings up a
selector so one can select the
Range of Cells to Import. When
done one clicks the  button
then selects Import:

13.The data will appear in the
SharePoint list
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SharePoint Workspace

The SharePoint Workspace is essentially a way for a user to organize and work on their
files on a local basis and thus if desired synchronize files with a SharePoint
environment. The SharePoint Workspace is available out of the box if a user is running
the Office 2010 Professional edition.

1. To access the
workspace for
the first time
from Start ->
Microsoft Office
-> select
Microsoft
SharePoint
Workspace
2010.
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2. Select from the
menu Create a
new account
and click Next

3. The account is
created

4. At the Create
Account screen
select Create
the account
using your e-
mail address
and then enter
in the Name:
and E-mail
Address: fields
as desired and
check Allow me
to recover my
account later
and then select
Finish.
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5. The Create
Account screen
is shown.

6. The Launchbar
is displayed.

7. Select from the
File menu ->
SharePoint
Workspace
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8. Enter in the URL
of the desired
SharePoint
environment
site(example
http://myfirmintr
anet.myfirm.com
/dept/myteam

9. Click Configure

10.Click OK so that
the desired site
is synced to the
workspace.
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11.Select the
directory where
the files(s)
should be
synced into.

12.Select File->Add
Documents

HTTP://WWW.KMO.NAME
mailto:ONEILLWEBSITE@VERIZON.NET


W E B S I T E : H T T P : / / W W W . K M O . N A M E
E - M A I L : O N E I L L W E B S I T E @ V E R I Z O N . N E T

U S E  A L L  C O M M A N D S  A T O W N  R I S K

13.Browse to the
directory of the
file that should
be synced into
the workspace
from the
SharePoint
server and click
OK.

14.The file displays
in the
workspace in
the directory
chosen.

15.Select File ->
Sync -> Sync
Workspace.

NOTE: Lower right hand side of workspace tells one the
status:
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16.In this case, it is
a good idea to
go to the
SharePoint site
– Access Site
Actions -> View
All Site Content
and in this case
I selected
Customized
Report since
that is where I
uploaded the
item to in my
workspace.
Note it was
uploaded to the
SharePoint
environment.

17.Once a file is
synced into a
workspace – if
one wants to
work on the file
while off the
network
(example at
home) then they
can select File -
> Info select
Connection
Settings and
click Work
Offline.
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SharePoint mySites

In SharePoint 2010 the notion of mySites allows for a more social experience to users
of SharePoint. Users can now update their status, connect with other individuals as well
as share content freely amongst other items.

1. If mySites are
turned on
then from Site
Actions -> the
following
option will be
available
typically
under your
login name.

2. The default
page of a My
Site will
appear as
such.

3. Clicking My
Colleagues
brings one to
a page where
they can add
and edit those
individuals
whom they
want to follow
the activities
of.

4. At the
following
screen click
Add
Colleagues
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5. In the
Colleagues
section –
enter in the
individual’s
names whom
you wish to
follow or click
the browse
book and find
the individuals
– click Add
then click OK.
If the users
are members
of your team
click the
proper
selection
under this
option.
Additionally in
the Add to
Group add
the users to a
desired group
or create a
new group.
Finally, in the
Show to -
select whom
should see
the
colleagues in
your profile.
Select OK
when done.
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6. Click View
Suggestions
and if prompted
to Configure
My Site for
Microsoft Office
– click Yes.
Then the
display shows
those people
whom you most
likely have
connected with
via e-mail and
instant
messenger.
Check those
users whom
you wish to
connect with. If
the users are
members of
your team click
the proper
selection under
this option.
Additionally in
the Add to
Group add the
users to a
desired group
or create a new
group. Finally,
in the Show to -
select whom
should see the
colleagues in
your profile.
Select OK
when done.
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7. Edit Colleagues
– on the
Colleagues tab
first check
those
individuals
whom you want
to edit – then
click the Edit
Colleagues
link. Edit the
information that
displays as
desired then
click Save and
Close.

8. Remove
Colleagues - on
the Colleagues
tab first check
those
individuals
whom you want
to remove –
then click the
Remove
Colleagues
link.

9. Another piece
of functionality
of value on the
My Colleagues
is the What’s
Happening
balloon.

10.Click into the
balloon and
then enter in
your text – in
this case “This
is a test” was
entered. When
done hit the
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enter key.
11.Click the Edit

My Profile link
to update your
profile.

12.Enter in the
desired
information into
the profile – a
sampling of
fields is shown
here - click
Save and
Close.

13.Once
completed click
the Overview
tab to view
some of the
information
entered into the
profile. Click
the More
information link
to see the
hidden
information
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14.Moving left to
right across the
Organization
tab – when
selected this
displays a
Silverlight
Control of the
relationships to
you in the
organization.  It
is based upon
whom you
select to be on
your team as
well as how the
information is
fed into the
mySites by the
farm
administrator(s)

15.Clicking the
Content tab
shows ones
SharePoint
documents
they have
uploaded or
sites they are
associated
with.
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16.Clicking Tags
and Notes
shows one the
items they have
previously
tagged within
SharePoint
itself. The tags
are essentially
shown in a tag
cloud which a
user can then
click those
words of
interest and
see the items
that were
tagged with
those said
keywords.

17.Clicking the
Memberships
tab shows one
the sites they
are members
of.

18.Clicking on the
My Site link on
the top
navigation
brings one
back to the
default My Site
page.

19.Clicking My
Interests
brings one to a
section of their
profile where
they can enter
in their
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interests
20.At this screen

one simply
enters in their
interests. When
done making
edits one
should select
Save and
Close.

21.Clicking on the
My Site link on
the top
navigation
brings one
back to the
default My Site
page.

22.The last section
on this page to
select is the
Newsfeed
Settings
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23.On this screen
of one’s profile
– a user selects
how e-mail
notifications
should be sent
and selects the
activities they
wish to follow
by checking
and unchecking
the selections.
When done
making edits
one should
select Save
and Close.

24.On the main
navigation it
should be
noted that the
Find People
search can
prove very
useful in finding
individuals.
Simply by
typing in the
desired term
and clicking the
magnifying
glass result
sets are
returned.
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25.On this same
navigation bar
a user can
navigate to
their My Site by
clicking that
link.

26.Additionally, a
user can
access their my
Newsfeed by
clicking that link

27.A user can
access their My
Content by
clicking that link

28.Finally, a user
can access
their My Profile
by selecting
that link

29.The first time
one accesses
their My profile
the profile
based on one’s
information
may take a
minute or two
to process.
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Real Simple Syndication (RSS)

RSS is available in SharePoint 2010 to create RSS feeds for a list and library. This
allows one to not only view – but have a mechanism available to distribute news items
of value to a targeted audience. One item to note is that the RSS Viewer web part
cannot be used to read SharePoint RSS feeds.

In order to set-up RSS follow these steps:

1. From the top level site
select Site Actions -> Site
Settings -> then select RSS
from the Site Administration
group

2. Select and enter in the
desired options then click
OK. Note that the
Copyright, Managing Editor
and Webmaster fields may
or may not appear in all
RSS viewers. Also the Time
to Live is the number of
minutes that users should
be waiting for updates to
the RSS feed.

3. RSS can also be enabled at
the list and library level as
well – thus access the
desired list or library and
select list or library settings.

4. For a list – from the List
Tools tab select List -> list
Settings then under
Communications -> RSS
settings.

5. For a library – from the
Library Tools tab select
Library then Library Settings
then under Communications
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-> RSS settings
6. In both cases under the List

RSS check Yes to Allow
RSS for this list.

7. Under RSS Channel
Information enter in the Title
and Description of the feed
as well as an Image URL if
desired.

8. Select under Document
Options – how attachments
should be displayed.

9. Under Columns – select the
desired columns to appear
in the feed.

10.Under item limit enter in the
Maximum number of items
to include and for how many
days back should be
included.

11.Click OK when done.
12.Feeds can be read by any

reader – in this case the out
of the box RSS reader with
Internet Explorer is used so
thus while on this page if
the RSS item is selected
then the feed itself – is
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engaged.
13.Once selected then the feed

can be subscribed to by
clicking the ‘Subscribe to
this feed’ link.

14.When prompted select the
Subscribe button.

15. In Internet Explorer 8 by
clicking favorites the RSS
feed just subscribed to is
shown and can be
accessed as desired.
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InfoPath

InfoPath

InfoPath is a toolset designed for power users to create forms that users can then fill in.
The InfoPath designer tool is available with the Microsoft Professional Office 2010
edition. Also it should be noted when designing forms – so that a client piece of InfoPath
(named the Microsoft InfoPath Filler 2010) does not have to be installed on every
computer that is to use the form that is created – a web-site version of the form should
be created for better architecture and flexibility.

The steps below cover creating a simple InfoPath Form

1. Access the
InfoPath
Designer
2010 –
found from
Start ->
Microsoft
Office ->
Microsoft
InfoPath
Designer
2010

2. Select No if
prompted
unless you
wish .xml
files to open
in InfoPath

3. Under
Popular
Form
Templates
double click
Blank
Forms
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4. The
screens
middle
section will
appear as
such:

5. Click to add
title and
type in
“Test”

6. On the
Page
Design tab
click a
selection –
in this case
Professiona
l – Ricasso
was
selected.

7. Select the
Home tab –
then place
the cursor
on the title
line (where
it says Test)
– hit enter
once then
from the
toolbox
select the
Date Picker

HTTP://WWW.KMO.NAME
mailto:ONEILLWEBSITE@VERIZON.NET


W E B S I T E : H T T P : / / W W W . K M O . N A M E
E - M A I L : O N E I L L W E B S I T E @ V E R I Z O N . N E T

U S E  A L L  C O M M A N D S  A T O W N  R I S K

8. The date
picker is
added to
the form

9. In the
Ribbon
select the
Preview
button
which is
likely on the
far right –
under the
Form group

10.The form is
shown and
the control
that was
added can
be selected

11.On the
ribbon
select the
Close
Preview
button –
under the
Preview
section
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12.At this point
– select File
-> Save As
and save
and name
the form
into a
directory of
your choice

13.To publish
the form to
SharePoint
– from the
File tab –
select
Publish

14.Select
SharePoint
Server

15.Enter in the
name of the
SharePoint
site and
click Next
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16.A wizard
will then run

17.When
prompted
check
“Enable this
form to be
filled out by
using a
browser”
and select
Form
Library then
select Next

18.The server
will be
contacted
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19.In this
example
“Create a
new form
library” will
be selected
– then Next:

20.A name
“Test
Forms” was
entered and
Next
selected:
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21.Select Next
as in this
example we
will not be
adding
columns or
parameters
to
SharePoint
sites and
Outlook
folders:

22.Verify
information
– then
select
Publish:

23.The wizard
will run
through and
create
connections
as needed
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24.When
completed
make the
desired
selection
and click
Close when
desired:

25. In this
example –
“Open this
form in the
browser”
was
selected

26.The form
was then
displayed
for entering
in data:
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